Tags:
Node Thumbnail

เมื่อครู่ผมได้ลอง build iOS application จากโปรแกรม Xcode เพื่อทำการทดสอบโดยมี target ไปที่ iPhone 6s Plus ที่ติดตั้ง iOS 11.2 แล้วพบว่าไม่สามารถติดตั้ง application ได้ ทั้งที่ใช้ Xcode 9.1 ซึ่งเป็นรุ่นล่าสุดแล้ว

ทั้งนี้หากต้องการติดตั้ง application บน iOS 11.2 จริง ต้องติดตั้ง Xcode 9.2 beta ที่มีให้สำหรับนักพัฒนาไปก่อน

แต่อย่าลืมนะครับว่า Xcode ตัว beta นั้นไม่สามารถ build application เพื่อส่งขึ้น App Store ได้

No Description

อัพเดท - คืนวันที่ 4 ธันวาคม แอปเปิลออก Xcode 9.2 ไม่ beta ให้โหลดได้จาก App Store แล้ว

Get latest news from Blognone

Comments

By: PH41
ContributorAndroidUbuntuWindows
on 3 December 2017 - 21:41 #1022062
PH41's picture

ผมใส่ <!--break--> แล้วไม่ break ให้

By: hisoft
ContributorWindows PhoneWindows
on 3 December 2017 - 22:06 #1022066 Reply to:1022062
hisoft's picture

ใช้ break ไม่ได้แล้วครับ ก็อปแยกส่วนหน้าแรกกับเนื้อหาเต็มเอา

By: PH41
ContributorAndroidUbuntuWindows
on 3 December 2017 - 22:27 #1022067 Reply to:1022066
PH41's picture

ได้แล้วครับ ขอบคุณครับ

By: illuminator
ContributorAndroidUbuntuWindows
on 6 December 2017 - 10:01 #1022366 Reply to:1022066
illuminator's picture

อย่างงี้นี่เอง ผมก็ใช้ไม่ได้หลายรอบแล้ว ก๊อปแปะเองล้วนๆ ?


The softest water wears down the hardest rock.

By: EliteP
iPhoneAndroidWindows
on 4 December 2017 - 11:57 #1022111

Apple นัก hardcoded ในตำนาน ไม่เคยสนใจ backward compat. เลย

By: Perl
ContributoriPhoneUbuntu
on 4 December 2017 - 11:59 #1022112
Perl's picture

จะเปลี่ยนป้าย iOS 11 เป็น iOS 11 beta แทนไหม

By: thongpak21 on 4 December 2017 - 12:10 #1022114

จริงๆแล้วไปแกะ Device Support iOS 11.2 ที่อยู่ใน Xcode ตัว Beta มาใส่ใน Xcode ตัว Release ก็ Build ได้แล้วครับ

By: phakphumi
AndroidWindows
on 4 December 2017 - 12:16 #1022115

อ่านแล้วเหมือนเป็นกระทู้บ่นปัญหาที่เจอมากกว่าเป็นข่าว

By: heart
ContributoriPhone
on 4 December 2017 - 12:20 #1022116 Reply to:1022115
heart's picture

ผมทำ iOS App อยู่ ผมถือว่านี่เป็นข่าวนะครับ

เพราะผมได้ประโยชน์ จากข่าวนี้
ผมไม่ได้รู้สึกว่า แค่บ่น

By: sp on 4 December 2017 - 12:37 #1022119

อ่านใน developer forum บอกว่า ios 11.2 ออกก่อนกำหนดเพื่อแก้ปัญหาเรื่อง boot loop ให้กับลูกค้าทั้งหมด คาดว่า version ใหม่ของ xcode จะออกมาเร็ว ๆ นี้ อย่างไรก็ดี ได้มีคำแนะนำสำหรับนักพัฒนามานานแล้วว่า ไม่ควร update ios firmware ของอุปกรณ์ที่ใช้ทดสอบ ถ้า xcode ยังไม่รองรับ ได้อ่านบ้างหรือเปล่าครับ?

By: heart
ContributoriPhone
on 4 December 2017 - 12:38 #1022121 Reply to:1022119
heart's picture

น่าจะไม่ได้อ่านกันหลายคนเลยครับ
เพราะมันขัดกับความเคยชินครับ

ผมเองก็ไม่ได้อ่าน

ที่ผ่านมา ตั้งแต่ผมเขียน iOS มาหลายปี
มันก็จะออกมาพร้อม xcode ทุกๆรอบครับ เลยกลายเป็นความเคยชินไปแล้ว (เพราะมันหลายปีจริงๆ)

เลยไม่น่าแปลกใจว่า ทำไมไม่ค่อยมีใครไปอ่าน

By: danya0365
iPhoneAndroidWindows
on 4 December 2017 - 14:08 #1022132

อะไรคือความหมายของงานเข้าครับ

Dev Apple ทุกคนน่าจะรุ้หมด ถ้า iPhone ออกอัพเดตใหม่ แล้ว Xcode ไม่มีอัพเดต มันก็ Build ไม่ได้อยู่แล้ว

คือมันเป็นแบบนี้มาตลอด หลายปี แค่ครั้งนี้ XCode มันยังไม่ปล่อยอัพเดตออกมา แค่นั้นเอง

By: john dick
iPhone
on 4 December 2017 - 14:41 #1022133 Reply to:1022132
john dick's picture

คงอยากให้เหล่าสาวก apple งานเข้าละมั้ง จะได้มาเม้นกันเยอะๆ

ส่วนตัวเกลียด apple เพราะขายแพง กว่าจะมี Ecosystem ครบ ล่อไปหลายแสน

By: readonly
iPhone
on 5 December 2017 - 08:44 #1022222 Reply to:1022133
readonly's picture

ก็ไม่จำเป็นต้องมีให้ครบนี่นะ

By: Bluetus
iPhone
on 4 December 2017 - 15:01 #1022139 Reply to:1022132
Bluetus's picture

lol

By: thanyadol
iPhone
on 4 December 2017 - 16:32 #1022154

หุหุ

By: jarujit
ContributoriPhoneAndroid
on 4 December 2017 - 17:00 #1022159
jarujit's picture

กลายเป็นความผิดของ dev ซะงั้น ?


:-)

By: tg-thaigamer
ContributoriPhoneAndroidBlackberry
on 4 December 2017 - 22:56 #1022202
tg-thaigamer's picture

อดทนกันไป ขาลงของ iOS สักพักนึงมันจะดีขึ้นเอง


มือใหม่!! ใหม่จริงๆนะ

By: jedising
iPhone
on 5 December 2017 - 07:50 #1022218

ใจเย็นๆกันฮะ 9.2 ออกละฮะ

By: kajokman
ContributorAndroidIn Love
on 5 December 2017 - 12:34 #1022252
kajokman's picture

แล้วพวกที่ใช้ CICD จะโดนป่าวครับ เดาว่าไม่นะ