Tags:
Node Thumbnail

Google Play Services ประกาศหยุดซัพพอร์ต Android API level 14-15 หรือ Android 4.0 Ice Cream Sandwich (ICS)

เหตุผลคือผู้ใช้งาน ICS ลดน้อยลงเหลือไม่ถึง 1% ของผู้ใช้ Android ทั้งหมดแล้ว (ICS เองก็มีอายุ 7 ปีแล้ว) ส่งผลให้กูเกิลตัดสินใจหยุดรองรับ ICS และแนะนำให้นักพัฒนาแอพขยับเวอร์ชัน API เป็น 16 (Android 4.1 Jelly Bean) แทน

ข้อมูลจาก Android Platform Versions ในตอนนี้ มีผู้ใช้งาน Android เวอร์ชันเก่าดังนี้

  • Android 2.3 Gingerbread 0.2%
  • Android 4.0 Ice Cream Sandwich 0.3%
  • Android 4.1 Jelly Bean 1.1%
  • Android 4.2 Jelly Bean 1.5%
  • Android 4.3 Jelly Bean 0.4% (รวม Jelly Bean ทั้งหมด 3.0%)
  • Android 4.4 Kit Kat 7.6%

ที่มา - Android Developers Blog

No Description

ภาพจาก @Android

Get latest news from Blognone

Comments

By: sudoku144
AndroidUbuntuWindows
on 8 December 2018 - 11:10 #1086123
sudoku144's picture

งี้ต้องหยุดซัพพอร์ต Android P ด้วยมั้ยเนี่ย ไม่ถึง 1% เหมือนกัน

By: darknw on 8 December 2018 - 12:11 #1086135 Reply to:1086123
darknw's picture

เข้าใจว่าประชดแต่ไม่ make sense อันนี้เป็นหน้าที่ของแต่ละแบรนด์เรื่องของอัพเดท OS

By: ash_to_ash
AndroidWindows
on 8 December 2018 - 12:30 #1086139 Reply to:1086123

โทรศัพท์ดอรยด์ที่อายุ 5ปี+ ผมว่าแทบไม่มีคนใช้แล้วนะ
สมมติ ICS นี่ผมว่าตั้งกะปี 2011-12 อาจจะหลุดมาบางใน 2013
แต่ก็เป็นสเปคต่ำๆอย่าง rom 4 ram 256 มันยังรันได้อยู่จริงหรือ Maxสุด ก็ Rom 8/16 Ram 1

By: sarajung
iPhoneWindows PhoneAndroid
on 8 December 2018 - 12:40 #1086141 Reply to:1086139
sarajung's picture

5 ปี คนยังใช้อยู่ครับ เช่น note 2 ยังเห็นหบายคนใช้งานได้้ดีอยู่ดลย

By: zyzzyva
Blackberry
on 8 December 2018 - 15:48 #1086159 Reply to:1086139

นี่ผมก็ยังใช้ Nexus 5 ที่ซื้อวันที่ 6 ธค 2013 พิมพ์ตอบความเห็นนี้นะครับ (และกะจะใช้จนกว่า Pixel 4 ออกเลยทีเดียว)
แต่อาจเป็นเพราะมันเป็น flagship + Nexus ด้วยมั้งเลยใช้ได้นาน ถ้าเป็นมือถือตลาดล่างแอนดรอยด์นี่คงอยู่ไม่ถึง

By: zyzzyva
Blackberry
on 8 December 2018 - 13:35 #1086144 Reply to:1086123

ทางข่าวต้นทางชัดเจนกว่า (แต่ที่แปลมาก็พอจะได้ใจความ)
The Android Ice Cream Sandwich (ICS) platform is seven years old and the active device count has been below 1% for some time.
นั่นหมายถึงว่าการที่จะหยุดซัพพอร์ตต้องปลดล็อกทั้งสองเงื่อนไข (เพราะใช้คำว่า และ/and ไม่ใช่ หรือ/or)
1. อายุเจ็ดปี
2. ต่ำกว่า 1%
Android P ปลดล็อกแค่เงื่อนไขที่สอง เลยยังไม่หยุดซัพพอร์ตครับ

By: sdc on 8 December 2018 - 13:43 #1086145

ทำไมไม่หยุดครั้งแต่ 5-6 ย้อนไปอ่ะ แล้วอีกซัก 2 ปีขยับเป็น 7
หรือ หยุด support หลังตัวใหม่ ย้อนไป 3 version

By: horakung
iPhoneAndroidWindows
on 8 December 2018 - 14:05 #1086149
horakung's picture

เครื่องที่ใช้เกิน 5 ปี เหลือแค่ SSGS 2 แต่ Gift เวอร์ชั่นล่าสุดดันบอกว่า ไม่ให้ใช้กับมือถือเกิน 5 ปี แล้ว... คงได้ทิ้งละ

By: tom789
Windows Phone
on 8 December 2018 - 14:17 #1086151

น่าจะดัน ไป ที่ 5.0 ได้แล้ว นะครับ

By: pexza
AndroidUbuntuWindows
on 8 December 2018 - 15:38 #1086157
pexza's picture

กล่องด๋อยตายหยังเขียดเลยนะนั่น

By: Mikamura
AndroidUbuntuWindows
on 9 December 2018 - 19:16 #1086221 Reply to:1086157

กล่องด๋อยส่วนใหญ่เป็น 4.4 ครับ

By: akira on 8 December 2018 - 16:19 #1086161

อุปกรณ์มือถือฝั่ง Entetprise น่าจะโดนกันหลายตัว

By: tekkasit
ContributorAndroidWindowsIn Love
on 10 December 2018 - 08:06 #1086268
tekkasit's picture

มือถือก็อาจจะต้องพึ่ง รอมอื่นๆ ที่น่าเชื่อถือหน่อย อย่าง LneageOS

แต่พวก set-top box หรือพวก E-Book reader นี่น่าจะแย่