Tags:
Node Thumbnail

ปัญหาอย่างหนึ่งของแอนดรอยด์ คือการใช้เคอร์เนลลินุกซ์ที่เก่ามาก (แอนดรอยด์ใช้ 3.18 ที่ออกในปี 2014 ส่วนเคอร์เนลเวอร์ชันล่าสุดคือ 4.11)

Dave Burke หัวหน้าทีมวิศวกรรมแอนดรอยด์ ตอบคำถามเรื่องนี้ในบทสัมภาษณ์กับ Ars Technica ว่าเคอร์เนล 3.18 เป็นเคอร์เนลที่ซัพพอร์ตระยะยาว (LTS) ซึ่งมันหมดอายุซัพพอร์ตแล้วในเดือนมกราคม 2017

ปัญหาของเรื่องนี้เกิดจากแผนการซัพพอร์ต LTS ของลินุกซ์กับแอนดรอยด์มีระยะเวลาไม่เท่ากัน ลินุกซ์มีระยะซัพพอร์ต 2 ปี ส่วนแอนดรอยด์มีระยะซัพพอร์ตความปลอดภัย 3 ปี ทางแก้คือทีมแอนดรอยด์กำลังเจรจากับทีมลินุกซ์ให้ระยะการซัพพอร์ตยาวนานขึ้น

ตอนนี้แอนดรอยด์กำลังพัฒนาเคอร์เนลเวอร์ชัน 4.4 ใช้งานกันอยู่ภายใน ส่วนเป้าหมายในระยะยาวคือพยายามใช้เคอร์เนลที่ใหม่ขึ้น แต่ก็ต้องขึ้นกับผู้ผลิตชิปเซ็ต (เช่น Qualcomm) ช่วยซัพพอร์ตด้วยอีกทาง

ที่มา - Ars Technica, ภาพจาก Android

No Description

Get latest news from Blognone

Comments

By: mr_tawan
ContributoriPhoneAndroidWindows
on 1 June 2017 - 13:03 #990376
mr_tawan's picture

รอดูว่า Linus จะว่าไง


  • 9tawan.net บล็อกส่วนตัวฮับ
By: -Rookies-
ContributorAndroidWindowsIn Love
on 1 June 2017 - 13:06 #990377 Reply to:990376

น่าสนใจฮะ


เทคโนโลยีไม่ผิด คนใช้มันในทางที่ผิดนั่นแหละที่ผิด!?!

By: darkleonic
ContributorAndroidWindowsIn Love
on 1 June 2017 - 13:58 #990394 Reply to:990376
darkleonic's picture

หรือจะเป็นจุดแตกหักกัน?

By: osmiumwo1f
ContributorWindows PhoneWindows
on 1 June 2017 - 14:48 #990417 Reply to:990376

แทงว่าแกไม่สนใจ

By: pexza
AndroidUbuntuWindows
on 1 June 2017 - 13:25 #990386
pexza's picture

นึกว่าจะทิ้ง Kernel Linux เสียแล้ว